summaryrefslogtreecommitdiffstats
path: root/hcid/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-07-29 20:35:12 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-07-29 20:35:12 +0200
commite0581b5e29c71c4a0b429ebad671e9bb5583f8e0 (patch)
tree84606447fce9a17818965957296e8ee447b59450 /hcid/Makefile.am
parent6ff001317710e6cf629ad93db58db615a8be6eee (diff)
Move hcid to src directory and rename it to bluetoothd
Diffstat (limited to 'hcid/Makefile.am')
-rw-r--r--hcid/Makefile.am59
1 files changed, 0 insertions, 59 deletions
diff --git a/hcid/Makefile.am b/hcid/Makefile.am
deleted file mode 100644
index e9d93a30..00000000
--- a/hcid/Makefile.am
+++ /dev/null
@@ -1,59 +0,0 @@
-
-if CONFIGFILES
-dbusdir = $(sysconfdir)/dbus-1/system.d
-
-dbus_DATA = bluetooth.conf
-
-confdir = $(sysconfdir)/bluetooth
-
-conf_DATA = hcid.conf
-
-statedir = $(localstatedir)/lib/bluetooth
-
-state_DATA =
-endif
-
-sbin_PROGRAMS = hcid
-
-hcid_SOURCES = main.c hcid.h sdpd.h \
- sdpd-server.c sdpd-request.c sdpd-service.c \
- sdpd-database.c security.c storage.c \
- parser.h parser.y lexer.l kword.c kword.h \
- server.h server.c manager.h manager.c \
- adapter.h adapter.c device.h device.c plugin.h plugin.c \
- dbus-common.c dbus-common.h \
- dbus-database.c dbus-database.h dbus-service.c dbus-service.h \
- dbus-hci.h dbus-hci.c \
- telephony.h telephony.c agent.h agent.c
-
-hcid_LDADD = $(top_builddir)/common/libhelper.a \
- @GDBUS_LIBS@ @GMODULE_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
-
-if MAINTAINER_MODE
-plugindir = $(abs_top_srcdir)/plugins
-else
-plugindir = $(libdir)/bluetooth/plugins
-endif
-
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ \
- @GLIB_CFLAGS@ @GMODULE_CFLAGS@ @GDBUS_CFLAGS@ \
- -DPLUGINDIR=\""$(plugindir)"\"
-
-INCLUDES = -I$(top_srcdir)/common
-
-BUILT_SOURCES = parser.h
-
-if MANPAGES
-man_MANS = hcid.8 hcid.conf.5
-endif
-
-AM_YFLAGS = -d
-
-CLEANFILES = lexer.c parser.c parser.h
-
-EXTRA_DIST = bluetooth.conf hcid.8 hcid.conf.5 hcid.conf dbus-api.txt \
- list-devices test-discovery test-manager test-adapter test-device \
- simple-service simple-agent service-record.dtd \
- service-did.xml service-spp.xml service-opp.xml service-ftp.xml
-
-MAINTAINERCLEANFILES = Makefile.in