summaryrefslogtreecommitdiffstats
path: root/hcid/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2004-02-17 18:04:03 +0000
committerMarcel Holtmann <marcel@holtmann.org>2004-02-17 18:04:03 +0000
commitf17bb94f47090f3397b60b5e264aa9f18dbf203d (patch)
treecd475c5e55def20433d0ac0e83a0410e0606da91 /hcid/Makefile.am
parent5903cfe8fdfa5df4a0ce737219385d16da85e279 (diff)
Add D-Bus support for PIN request
Diffstat (limited to 'hcid/Makefile.am')
-rw-r--r--hcid/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/hcid/Makefile.am b/hcid/Makefile.am
index 378d3a35..14428722 100644
--- a/hcid/Makefile.am
+++ b/hcid/Makefile.am
@@ -4,7 +4,13 @@
sbin_PROGRAMS = hcid
-hcid_SOURCES = main.c security.c hcid.h lib.c lib.h parser.h parser.y lexer.l kword.h kword.c glib-ectomy.h glib-ectomy.c
+if ENABLE_DBUS
+dbus_hcid_sources = dbus.c
+else
+dbus_hcid_sources =
+endif
+
+hcid_SOURCES = main.c security.c hcid.h lib.c lib.h parser.h parser.y lexer.l kword.h kword.c glib-ectomy.h glib-ectomy.c $(dbus_hcid_sources)
hcid_CONFIG = hcid.conf
YFLAGS = -d