summaryrefslogtreecommitdiffstats
path: root/sbc/Makefile.am
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@nokia.com>2009-01-15 19:11:23 +0200
committerMarcel Holtmann <marcel@holtmann.org>2009-01-16 00:28:32 +0100
commit9e31e7dde636ca28ee551e8bcf8e4f4ca0ef553d (patch)
treeefc05cd31c23eb871dcff2ed3776473e38a3d003 /sbc/Makefile.am
parent5331a26b8a3c2d69d30a4334e023238db197080b (diff)
SIMD-friendly variant of SBC encoder analysis filter
Added SIMD-friendly C implementation of SBC analysis filter (the structure of code had to be changed a bit and constants in the tables reordered). This code can be used as a reference for developing platform specific SIMD optimizations. These functions are put into a new file 'sbc_primitives.c', which is going to contain all the basic stuff for SBC codec.
Diffstat (limited to 'sbc/Makefile.am')
-rw-r--r--sbc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sbc/Makefile.am b/sbc/Makefile.am
index c42f1622..cd068e76 100644
--- a/sbc/Makefile.am
+++ b/sbc/Makefile.am
@@ -8,7 +8,8 @@ endif
if SBC
noinst_LTLIBRARIES = libsbc.la
-libsbc_la_SOURCES = sbc.h sbc.c sbc_math.h sbc_tables.h
+libsbc_la_SOURCES = sbc.h sbc.c sbc_math.h sbc_tables.h \
+ sbc_primitives.c
libsbc_la_CFLAGS = -finline-functions -funswitch-loops -fgcse-after-reload