summaryrefslogtreecommitdiffstats
path: root/sbc/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-10-25 11:06:39 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-10-25 11:06:39 +0000
commit582a5f9cca7f8ae1f41076c8c3bc9c3bae851b09 (patch)
tree51ff2d26d58b7e1d4082bcb84d4a3dccc1db3cfe /sbc/Makefile.am
parenta6b3daeb44d9b6f0d47fbe0cbfc6612c061352cd (diff)
Add build magic around sbctester program
Diffstat (limited to 'sbc/Makefile.am')
-rw-r--r--sbc/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/sbc/Makefile.am b/sbc/Makefile.am
index 46cb30be..840fbfef 100644
--- a/sbc/Makefile.am
+++ b/sbc/Makefile.am
@@ -1,14 +1,26 @@
+if SNDFILE
+sndfile_programs = sbctester
+else
+sndfile_programs =
+endif
+
if SBC
noinst_LTLIBRARIES = libsbc.la
libsbc_la_SOURCES = sbc.h sbc.c sbc_math.h sbc_tables.h
-noinst_PROGRAMS = sbcinfo sbcdec sbcenc
+noinst_PROGRAMS = sbcinfo sbcdec sbcenc $(sndfile_programs)
sbcdec_LDADD = libsbc.la
sbcenc_LDADD = libsbc.la
+
+if SNDFILE
+sbctester_LDADD = @SNDFILE_LIBS@
endif
+endif
+
+AM_CFLAGS = @SNDFILE_CFLAGS@
MAINTAINERCLEANFILES = Makefile.in