summaryrefslogtreecommitdiffstats
path: root/serial/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-07-26 19:00:53 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-07-26 19:00:53 +0200
commitd6ae1c3f777832f8e32702f81fe64e33a1396928 (patch)
tree159a1e59f3929c9d795dbd1f3edd84d9dccba048 /serial/Makefile.am
parentb8e5fea8d31fbcd3d1c044385f8217dbf39892bb (diff)
parent3382af9114a9b2e657c7ddd0a5511edda6a37a90 (diff)
Import bluez-utils-3.36 revision history
Diffstat (limited to 'serial/Makefile.am')
-rw-r--r--serial/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/serial/Makefile.am b/serial/Makefile.am
new file mode 100644
index 00000000..0e6c47f7
--- /dev/null
+++ b/serial/Makefile.am
@@ -0,0 +1,24 @@
+
+if SERIALPLUGIN
+plugindir = $(libdir)/bluetooth/plugins
+
+plugin_LTLIBRARIES = serial.la
+
+serial_la_SOURCES = main.c \
+ manager.h manager.c port.h port.c \
+ storage.h storage.c
+
+LDADD = $(top_builddir)/common/libhelper.a \
+ @GDBUS_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+endif
+
+AM_LDFLAGS = -module -avoid-version -no-undefined \
+ -export-symbols-regex bluetooth_plugin_desc
+
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
+
+INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/hcid -I$(top_srcdir)/sdpd
+
+EXTRA_DIST = serial-api.txt test-serial
+
+MAINTAINERCLEANFILES = Makefile.in