summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-01-20 05:26:15 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-01-20 05:26:15 +0000
commit8cc5595d9091b484b9a4abe314c0f3ec055e0581 (patch)
tree0d20c6f621673dbdb6095fb4854077152c1d9b40 /test/Makefile.am
parent884cfe825db1a0e8c98aa6a604fd4588a1de1340 (diff)
Make it possible to support an embedded GLib
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 18989ba5..c2a456d5 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,12 +1,4 @@
-if GLIB
-glib_cflags = @GLIB_CFLAGS@
-glib_ldadd = @GLIB_LIBS@
-else
-glib_cflags =
-glib_ldadd =
-endif
-
if TEST
sbin_PROGRAMS = hciemu
@@ -14,7 +6,8 @@ bin_PROGRAMS = l2test rctest
noinst_PROGRAMS = sdptest scotest attest hstest bdaddr lmptest
-hciemu_LDADD = $(glib_ldadd) @BLUEZ_LIBS@ $(top_builddir)/common/libhelper.a
+hciemu_LDADD = $(top_builddir)/common/libhelper.a \
+ @GLIB_LIBS@ @BLUEZ_LIBS@
l2test_LDADD = @BLUEZ_LIBS@
@@ -36,7 +29,7 @@ lmptest_LDADD = @BLUEZ_LIBS@
noinst_MANS = bdaddr.8
-AM_CFLAGS = @BLUEZ_CFLAGS@ $(glib_cflags)
+AM_CFLAGS = @BLUEZ_CFLAGS@ @GLIB_CFLAGS@
endif
INCLUDES = -I$(top_srcdir)/common