summaryrefslogtreecommitdiffstats
path: root/audio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'audio/Makefile.am')
-rw-r--r--audio/Makefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/audio/Makefile.am b/audio/Makefile.am
index 63f338b7..4de6d59f 100644
--- a/audio/Makefile.am
+++ b/audio/Makefile.am
@@ -1,18 +1,27 @@
-servicedir = $(libdir)/bluetooth
+if HEADSETSERVICE
+if CONFIGFILES
+confdir = $(sysconfdir)/bluetooth
-noinst_PROGRAMS = bluetoothd-service-audio \
- bluetoothd-service-headset
+conf_DATA = headset.service
+endif
-bluetoothd_service_audio_SOURCES = main.c manager.h manager.c
+servicedir = $(libdir)/bluetooth
-bluetoothd_service_audio_LDADD = $(top_builddir)/common/libhelper.a \
- @SBC_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+service_PROGRAMS = bluetoothd-service-headset
bluetoothd_service_headset_SOURCES = headset.c
bluetoothd_service_headset_LDADD = $(top_builddir)/common/libhelper.a \
- @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+endif
+
+noinst_PROGRAMS = bluetoothd-service-audio
+
+bluetoothd_service_audio_SOURCES = main.c manager.h manager.c
+
+bluetoothd_service_audio_LDADD = $(top_builddir)/common/libhelper.a \
+ @SBC_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @SBC_CFLAGS@