summaryrefslogtreecommitdiffstats
path: root/cups/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cups/Makefile.am')
-rw-r--r--cups/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/cups/Makefile.am b/cups/Makefile.am
index 7d5cadf4..0573a4af 100644
--- a/cups/Makefile.am
+++ b/cups/Makefile.am
@@ -3,13 +3,19 @@ if CUPS
cupsdir = $(libdir)/cups/backend
cups_PROGRAMS = bluetooth
-else
-noinst_PROGRAMS = bluetooth
-endif
bluetooth_SOURCES = main.c sdp.c spp.c hcrp.c
-bluetooth_LDADD = @BLUEZ_LIBS@
-AM_CFLAGS = @BLUEZ_CFLAGS@
+bluetooth_LDADD = $(top_builddir)/common/libhelper.a \
+ @DBUS_LIBS@ @GLIB_LIBS@ @BLUEZ_LIBS@
+
+if EXPAT
+bluetooth_LDADD += -lexpat
+endif
+endif
+
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
+
+INCLUDES = -I$(top_srcdir)/common
MAINTAINERCLEANFILES = Makefile.in