summaryrefslogtreecommitdiffstats
path: root/cups/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cups/Makefile.am')
-rw-r--r--cups/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/cups/Makefile.am b/cups/Makefile.am
index 42f3ac2f..c43cac54 100644
--- a/cups/Makefile.am
+++ b/cups/Makefile.am
@@ -2,17 +2,16 @@
# $Id$
#
-noinst_PROGRAMS = bluetooth
+if CUPS
+cupsdir = $(libdir)/cups/backend
+
+cups_PROGRAMS = bluetooth
bluetooth_SOURCES = main.c sdp.c spp.c hcrp.c
-LIBS = @BLUEZ_LIBS@
+LDADD = @BLUEZ_LIBS@
AM_CFLAGS = @BLUEZ_CFLAGS@
+endif
MAINTAINERCLEANFILES = Makefile.in
-
-if CUPS
-install-data-local: bluetooth
- $(INSTALL) -D -m 755 $(srcdir)/bluetooth $(DESTDIR)@CUPS_BACKEND_DIR@/bluetooth
-endif