summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 2f13ade2..9f7a4a0e 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -7,7 +7,7 @@ glib_cflags =
glib_ldadd =
endif
-noinst_PROGRAMS = bluetoothd
+noinst_PROGRAMS = bluetoothd bluetoothd_echo
bluetoothd_SOURCES = main.c system.h \
manager.h manager.c database.h database.c \
@@ -17,6 +17,11 @@ bluetoothd_LDADD = $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@ \
$(top_builddir)/sdpd/libsdpserver.a \
$(top_builddir)/common/libhelper.a
+bluetoothd_echo_SOURCES = echo.c
+
+bluetoothd_echo_LDADD = $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@ \
+ $(top_builddir)/common/libhelper.a
+
if EXPAT
bluetoothd_LDADD += -lexpat
endif