summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am15
1 files changed, 2 insertions, 13 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 39eabc7b..214b2449 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -1,21 +1,12 @@
-if ECHOSERVICE
-if CONFIGFILES
-confdir = $(sysconfdir)/bluetooth
-
-conf_DATA = echo.service
-endif
-
-servicedir = $(libdir)/bluetooth
-
-service_PROGRAMS = bluetoothd-service-echo
+noinst_PROGRAMS = bluetoothd passkey-agent auth-agent \
+ bluetoothd-service-echo
bluetoothd_service_echo_SOURCES = echo.c
bluetoothd_service_echo_LDADD = \
$(top_builddir)/common/libhelper.a \
@GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
-endif
if CONFIGFILES
dbusdir = $(sysconfdir)/dbus-1/system.d
@@ -23,8 +14,6 @@ dbusdir = $(sysconfdir)/dbus-1/system.d
dbus_DATA = bluetooth.conf
endif
-noinst_PROGRAMS = bluetoothd passkey-agent auth-agent
-
bluetoothd_SOURCES = main.c system.h \
manager.h manager.c database.h database.c \
adapter.h adapter.c service.h service.c