summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 7bfce4a8..90fad65d 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -23,7 +23,7 @@ dbusdir = $(sysconfdir)/dbus-1/system.d
dbus_DATA = bluetooth.conf
endif
-noinst_PROGRAMS = bluetoothd
+noinst_PROGRAMS = bluetoothd passkey-agent auth-agent
bluetoothd_SOURCES = main.c system.h \
manager.h manager.c database.h database.c \
@@ -38,6 +38,14 @@ if EXPAT
bluetoothd_LDADD += -lexpat
endif
+passkey_agent_SOURCES = passkey-agent.c
+
+passkey_agent_LDADD = @DBUS_LIBS@
+
+auth_agent_SOURCES = auth-agent.c
+
+auth_agent_LDADD = @DBUS_LIBS@
+
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/sdpd