summaryrefslogtreecommitdiffstats
path: root/hcid/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hcid/Makefile.am')
-rw-r--r--hcid/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/hcid/Makefile.am b/hcid/Makefile.am
index 3a5e766a..3cbdfaa2 100644
--- a/hcid/Makefile.am
+++ b/hcid/Makefile.am
@@ -7,9 +7,11 @@ sbin_PROGRAMS = hcid
if DBUS
dbus_hcid_sources = dbus.c
dbus_hcid_ldflags = @DBUS_LIBS@
+dbus_hcid_cflags = -DENABLE_DBUS -DDBUS_API_SUBJECT_TO_CHANGE
else
dbus_hcid_sources =
dbus_hcid_ldflags =
+dbus_hcid_cflags =
endif
hcid_SOURCES = main.c security.c hcid.h lib.c lib.h parser.h parser.y lexer.l kword.h kword.c glib-ectomy.h glib-ectomy.c $(dbus_hcid_sources)
@@ -17,11 +19,11 @@ hcid_CONFIG = hcid.conf
LDFLAGS = $(dbus_hcid_ldflags) @BLUEZ_LIBS@
-INCLUDES = @BLUEZ_INCLUDES@ @DBUS_INCLUDES@
+INCLUDES = @BLUEZ_INCLUDES@ @DBUS_INCLUDES@ $(dbus_hcid_cflags)
man_MANS = hcid.8 hcid.conf.5
-YFLAGS = -d
+YFLAGS = -d
CLEANFILES = lexer.c parser.c parser.h