summaryrefslogtreecommitdiffstats
path: root/hcid/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hcid/Makefile.am')
-rw-r--r--hcid/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/hcid/Makefile.am b/hcid/Makefile.am
index b58cd823..48ca47b8 100644
--- a/hcid/Makefile.am
+++ b/hcid/Makefile.am
@@ -15,7 +15,7 @@ endif
sbin_PROGRAMS = hcid
-noinst_PROGRAMS = passkey-agent
+noinst_PROGRAMS = passkey-agent service-agent
hcid_SOURCES = main.c security.c device.c logging.c storage.c \
sdp.c sdp.h hcid.h parser.h parser.y \
@@ -31,6 +31,10 @@ passkey_agent_SOURCES = passkey-agent.c
passkey_agent_LDADD = @DBUS_LIBS@
+service_agent_SOURCES = service-agent.c
+
+service_agent_LDADD = @DBUS_LIBS@
+
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@
INCLUDES = -I$(top_srcdir)/common