summaryrefslogtreecommitdiffstats
path: root/network/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'network/Makefile.am')
-rw-r--r--network/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/network/Makefile.am b/network/Makefile.am
index 362c7af6..fe6e3110 100644
--- a/network/Makefile.am
+++ b/network/Makefile.am
@@ -1,15 +1,26 @@
+if NETWORKSERVICE
+if CONFIGFILES
+confdir = $(sysconfdir)/bluetooth
+
+conf_DATA = network.service
+endif
+
servicedir = $(libdir)/bluetooth
noinst_PROGRAMS = bluetoothd-service-network
-bluetoothd_service_network_SOURCES = main.c
+bluetoothd_service_network_SOURCES = main.c \
+ manager.h manager.c server.h server.c connection.h connection.c
LDADD = $(top_builddir)/common/libhelper.a \
- @DBUS_LIBS@ @BLUEZ_LIBS@
+ @DBUS_LIBS@ @BLUEZ_LIBS@
+endif
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@
INCLUDES = -I$(top_srcdir)/common
+EXTRA_DIST = network.service network-api.txt
+
MAINTAINERCLEANFILES = Makefile.in