summaryrefslogtreecommitdiffstats
path: root/pcmcia/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pcmcia/Makefile.am')
-rw-r--r--pcmcia/Makefile.am19
1 files changed, 7 insertions, 12 deletions
diff --git a/pcmcia/Makefile.am b/pcmcia/Makefile.am
index f46cdf04..59c16334 100644
--- a/pcmcia/Makefile.am
+++ b/pcmcia/Makefile.am
@@ -2,19 +2,14 @@
# $Id$
#
-pcmciadir = $(sysconfdir)/pcmcia
+datafiles = bluetooth bluetooth.conf
-EXTRA_DIST = bluetooth bluetooth.conf
+if PCMCIA
+pcmciadir = $(sysconfdir)/pcmcia
-MAINTAINERCLEANFILES = Makefile.in
+pcmcia_DATA = $(datafiles)
+endif
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pcmciadir)
- [ -f $(DESTDIR)$(pcmciadir)/bluetooth ] || \
- $(INSTALL_DATA) $(srcdir)/bluetooth $(DESTDIR)$(pcmciadir)
- [ -f $(DESTDIR)$(pcmciadir)/bluetooth.conf ] || \
- $(INSTALL_DATA) $(srcdir)/bluetooth.conf $(DESTDIR)$(pcmciadir)
+EXTRA_DIST = $(datafiles)
-uninstall-local:
- @rm -f $(DESTDIR)$(pcmciadir)/bluetooth
- @rm -f $(DESTDIR)$(pcmciadir)/bluetooth.conf
+MAINTAINERCLEANFILES = Makefile.in