summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index d88d9db6..b07bad4f 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -7,12 +7,17 @@ else
netlink_plugins =
endif
-plugin_LTLIBRARIES = $(netlink_plugins)
+if SERVICEPLUGIN
+service_plugins = service.la
+else
+service_plugins =
+endif
+
+plugin_LTLIBRARIES = $(netlink_plugins) $(service_plugins)
noinst_LTLIBRARIES = echo.la storage.la
echo_la_SOURCES = echo.c
-
storage_la_SOURCES = storage.c
if NETLINK
@@ -21,6 +26,10 @@ netlink_la_SOURCES = netlink.c
netlink_la_LIBADD = @NETLINK_LIBS@
endif
+if SERVICEPLUGIN
+service_la_SOURCES = service.c
+endif
+
AM_LDFLAGS = -module -avoid-version -no-undefined \
-export-symbols-regex bluetooth_plugin_desc