summaryrefslogtreecommitdiffstats
path: root/serial/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'serial/Makefile.am')
-rw-r--r--serial/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/serial/Makefile.am b/serial/Makefile.am
index 24506088..240429a6 100644
--- a/serial/Makefile.am
+++ b/serial/Makefile.am
@@ -1,15 +1,25 @@
-noinst_PROGRAMS = bluetoothd-service-serial
+if SERIALSERVICE
+if CONFIGFILES
+confdir = $(sysconfdir)/bluetooth
+
+conf_DATA = serial.service
+endif
+
+servicedir = $(libdir)/bluetooth
+
+service_PROGRAMS = bluetoothd-service-serial
bluetoothd_service_serial_SOURCES = main.c manager.h manager.c
LDADD = $(top_builddir)/common/libhelper.a \
@GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+endif
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
INCLUDES = -I$(top_srcdir)/common
-EXTRA_DIST = serial-api.txt
+EXTRA_DIST = serial.service serial-api.txt
MAINTAINERCLEANFILES = Makefile.in