summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 32b32b33..065ebdee 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,10 +6,7 @@ bin_PROGRAMS = l2test rctest
noinst_PROGRAMS = scotest attest hstest bdaddr
-hciemu_LDADD = @BLUEZ_LIBS@ \
- $(top_builddir)/common/libglib-ectomy.a \
- $(top_builddir)/common/liblist.a
-
+hciemu_LDADD = @BLUEZ_LIBS@ $(top_builddir)/common/libhelper.a
l2test_LDADD = @BLUEZ_LIBS@
@@ -21,16 +18,16 @@ attest_LDADD = @BLUEZ_LIBS@
hstest_LDADD = @BLUEZ_LIBS@
-bdaddr_SOURCES = bdaddr.c $(top_builddir)/tools/oui.h $(top_builddir)/tools/oui.c
+bdaddr_SOURCES = bdaddr.c
-bdaddr_LDADD = @BLUEZ_LIBS@
+bdaddr_LDADD = @BLUEZ_LIBS@ $(top_builddir)/common/libhelper.a
noinst_MANS = bdaddr.8
AM_CFLAGS = @BLUEZ_CFLAGS@
endif
-INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/tools
+INCLUDES = -I$(top_srcdir)/common
EXTRA_DIST = hsplay hsmicro bdaddr.8