summaryrefslogtreecommitdiffstats
path: root/transfer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'transfer/Makefile.am')
-rw-r--r--transfer/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/transfer/Makefile.am b/transfer/Makefile.am
index 02742923..babe164e 100644
--- a/transfer/Makefile.am
+++ b/transfer/Makefile.am
@@ -1,2 +1,15 @@
+if OBEX
+noinst_PROGRAMS = transferd
+
+transferd_SOURCES = main.c
+
+LDADD = $(top_builddir)/common/libhelper.a \
+ @DBUS_LIBS@ @OPENOBEX_LIBS@ @BLUEZ_LIBS@
+endif
+
+AM_CFLAGS = @BLUEZ_CFLAGS@ @OPENOBEX_CFLAGS@ @DBUS_CFLAGS@
+
+INCLUDES = -I$(top_srcdir)/common
+
MAINTAINERCLEANFILES = Makefile.in