summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-29 21:27:59 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-29 21:27:59 +0000
commit2a708128adc5e825471a3a63d6bc7a53005ae237 (patch)
tree7e37830efe0a32390e6faa8ab623fd8b59160638 /configure.in
parentccc4926813482545ea47e85e8d134d504c68f3e7 (diff)
2003-04-29 Havoc Pennington <hp@redhat.com>
* dbus/dbus.h: add "you have to define DBUS_API_SUBJECT_TO_CHANGE to use this library" to be sure people have the right expectations.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index abb309c5..07830d90 100644
--- a/configure.in
+++ b/configure.in
@@ -132,8 +132,14 @@ else
fi
fi
-# compress spaces in cflags
+changequote(,)dnl
+# let ourselves use our own unstable API
+CPPFLAGS="-DDBUS_API_SUBJECT_TO_CHANGE=1 $CPPFLAGS"
+# compress spaces in flags
CFLAGS=`echo "$CFLAGS" | sed -e 's/ +/ /g'`
+CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ +/ /g'`
+CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/ +/ /g'`
+changequote([,])dnl
if test x$enable_gcov = xyes; then
## so that config.h changes when you toggle gcov support
@@ -607,6 +613,8 @@ echo "
source code location: ${srcdir}
compiler: ${CC}
cflags: ${CFLAGS}
+ cppflags: ${CPPFLAGS}
+ cxxflags: ${CXXFLAGS}
Doxygen: ${DOXYGEN}
db2html: ${DB2HTML}