summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Shaw <joeshaw@novell.com>2003-06-15 10:45:07 +0000
committerJoe Shaw <joeshaw@novell.com>2003-06-15 10:45:07 +0000
commit496f1e18a95604ee9008d4a01d50248d0c5532fb (patch)
tree8140a675d75b2185a080804936a7edeb8e1a6dfc /configure.in
parent6a109938f7a4fc726997985b6de66cf573961986 (diff)
2003-06-15 Joe Shaw <joe@assbarn.com>
* configure.in: Check for socklen_t. * dbus/dbus-sysdeps.c: Define socklen_t if it's not defined. * test/test-segfault.c: Add #include <sys/time.h> * tools/Makefile.am: Add DBUS_X_CFLAGS to the INCLUDES since dbus-launch needs it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 613bf2dc..a51f8157 100644
--- a/configure.in
+++ b/configure.in
@@ -273,6 +273,22 @@ else
fi
fi
+dnl check for socklen_t
+AC_MSG_CHECKING(whether socklen_t is defined)
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <netdb.h>
+],[
+socklen_t foo;
+foo = 1;
+],dbus_have_socklen_t=yes,dbus_have_socklen_t=no)
+AC_MSG_RESULT($dbus_have_socklen_t)
+
+if test "x$dbus_have_socklen_t" = "xyes"; then
+ AC_DEFINE(HAVE_SOCKLEN_T,1,[Have socklen_t type])
+fi
+
dnl check for writev header and writev function so we're
dnl good to go if HAVE_WRITEV gets defined.
AC_CHECK_HEADERS(sys/uio.h, [AC_CHECK_FUNCS(writev)])