summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-30 21:24:41 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-30 21:24:41 +0000
commit987ce0abaa787246e452a7e431306fbe6cb68e19 (patch)
tree6530ac5d189f3d826b602c254db7e49560eb8d12 /configure.in
parent42d47c5f805b61892456b17a0e5b2632d73745bd (diff)
2003-04-30 Havoc Pennington <hp@redhat.com>
* configure.in: print a note when building with unit tests and without assertions
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 91759117..ffe7107f 100644
--- a/configure.in
+++ b/configure.in
@@ -638,6 +638,9 @@ echo "
if test x$enable_tests = xyes; then
echo "NOTE: building with unit tests increases the size of the installed library and renders it insecure."
fi
+if test x$enable_tests = xyes -a x$enable_asserts = xno; then
+ echo "NOTE: building with unit tests but without assertions means tests may not properly report failures (this configuration is only useful when doing something like profiling the tests)"
+fi
if test x$enable_gcov = xyes; then
echo "NOTE: building with coverage profiling is definitely for developers only."
fi