summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-07 02:01:53 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-07 02:01:53 +0000
commita7f69a41d5b82eb00da20b661181b490039bb70f (patch)
tree0f00e5c4b57ec22fba047c2a654604e4c86a4693 /configure.in
parent98572905e60cac7ea971aa0830e2a629bfff208d (diff)
2003-04-06 Havoc Pennington <hp@pobox.com>
* qt/Makefile.am (dbusinclude_HEADERS): install dbus-qt.h, from Colin Walters * configure.in: fixes to Qt detection from Colin Walters * doc/Makefile.am: Only remove generated docbook dirs if they exist, from Colin Walters * dbus/dbus-bus.c: change how we set well-known connections to NULL, so that it works if a single connection is stored in two well-known array slots. * test/Makefile.am: remove a lot of stuff that isn't immediately useful, it's in CVS history if we want it. * test/test-service.c: use dbus-mainloop instead of that watch.[hc] crack
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e908d3ee..907d78ca 100644
--- a/configure.in
+++ b/configure.in
@@ -350,9 +350,22 @@ AC_SUBST(DBUS_GLIB_THREADS_LIBS)
# Qt detection
have_qt=no
-if test -n "$QTDIR" -a -f $QTDIR/include/qglobal.h; then
+AC_MSG_CHECKING([for qglobal.h])
+if test -n "$QTDIR" -a -f "$QTDIR/include/qglobal.h"; then
have_qt=yes
- DBUS_QT_CXXFLAGS=-I$QTDIR/include
+ DBUS_QT_CXXFLAGS="-I$QTDIR/include"
+else
+ for dir in "${prefix}/include/qt" "/usr/include/qt3" "/usr/include/qt" "/usr/lib/qt/include"; do
+ if test -f "$dir/qglobal.h"; then
+ have_qt=yes
+ DBUS_QT_CXXFLAGS="-I$dir"
+ fi
+ done
+fi
+if test x"$have_qt" = x"yes"; then
+ AC_MSG_RESULT([found])
+else
+ AC_MSG_RESULT([not found])
fi
dnl linking to kdecore will give us a bit of help from libtool
@@ -360,10 +373,10 @@ if (! kde-config >& /dev/null); then
have_qt=no
else
kdelibs=`kde-config --install lib --expandvars 2>/dev/null`
- if test -z $kdelibs -a -f $kdelibs/libkdecore.la; then
+ if test -z $kdelibs -o ! -f $kdelibs/libkdecore.la; then
have_qt=no
else
- DBUS_QT_LIBS=$kdelibs/libkdecore.la
+ DBUS_QT_LIBS="$kdelibs/libkdecore.la"
fi
fi