summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-06-22 05:53:06 +0000
committerHavoc Pennington <hp@redhat.com>2003-06-22 05:53:06 +0000
commit93b5a19c9f0979b5f227760af2ce5a0d076521f9 (patch)
tree1704ae1cbebdfacc0ca5d7c98e9c90bf55b27fd3 /configure.in
parent8e99e853a7abbb5344240c35b66853eeaedca48e (diff)
2003-06-22 Havoc Pennington <hp@pobox.com>
* mono/*, gcj/*, configure.in, Makefile.am: Check in makefiles and subdirs for mono and gcj bindings. Neither binding actually exists, just trying to get through all the build and other boring bits.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in85
1 files changed, 83 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a51f8157..f2ca23e7 100644
--- a/configure.in
+++ b/configure.in
@@ -33,7 +33,8 @@ AC_ARG_ENABLE(checks, [ --enable-checks include sanity checks o
AC_ARG_ENABLE(docs, [ --enable-docs build documentation (requires Doxygen and jade)],enable_docs=$enableval,enable_docs=auto)
AC_ARG_ENABLE(gcov, [ --enable-gcov compile with coverage profiling instrumentation (gcc only)],enable_gcov=$enableval,enable_gcov=no)
AC_ARG_ENABLE(abstract-sockets, [ --enable-abstract-sockets use abstract socket namespace (linux only)],enable_abstract_sockets=$enableval,enable_abstract_sockets=auto)
-
+AC_ARG_ENABLE(gcj, [ --enable-gcj build gcj bindings],enable_gcj=$enableval,enable_gcj=no)
+AC_ARG_ENABLE(mono, [ --enable-mono build mono bindings],enable_mono=$enableval,enable_mono=no)
AC_ARG_WITH(xml, [ --with-xml=[libxml/expat] XML library to use])
AC_ARG_WITH(init-scripts, [ --with-init-scripts=[redhat] Style of init scripts to install])
@@ -134,6 +135,63 @@ else
fi
fi
+#### can't use AM_PROG_GCJ since it fails fatally if no gcj found
+AC_CHECK_PROGS(GCJ, gcj, gcj)
+if test -z "$GCJ" ; then
+ have_gcj=no
+else
+ have_gcj=yes
+ if test "x${GCJFLAGS-unset}" = xunset; then
+ GCJFLAGS="-g -O2 -Wall"
+ fi
+ AC_SUBST(GCJFLAGS)
+ _AM_IF_OPTION([no-dependencies],, [_AM_DEPENDENCIES(GCJ)])
+fi
+
+if test x$enable_gcj = xauto ; then
+ if test x$have_gcj = xno ; then
+ enable_gcj=no
+ else
+ enable_gcj=yes
+ fi
+fi
+
+if test x$enable_gcj = xyes; then
+ if test x$have_gcj = xno ; then
+ AC_MSG_ERROR([Building gcj explicitly required, but gcj not found])
+ fi
+fi
+
+AM_CONDITIONAL(DBUS_USE_GCJ, test x$enable_gcj = xyes)
+
+#### Look for mono
+AC_CHECK_TOOL(MCS, mcs, mcs)
+if test -z "$MCS" ; then
+ have_mcs=no
+else
+ have_mcs=yes
+ if test "x${MCSFLAGS-unset}" = xunset; then
+ MCSFLAGS="" ### put default MCSFLAGS here
+ fi
+ AC_SUBST(MCSFLAGS)
+fi
+
+if test x$enable_mono = xauto ; then
+ if test x$have_mcs = xno ; then
+ enable_mono=no
+ else
+ enable_mono=yes
+ fi
+fi
+
+if test x$enable_mono = xyes; then
+ if test x$have_mcs = xno ; then
+ AC_MSG_ERROR([Building Mono bindings explicitly required, but mcs compiler not found])
+ fi
+fi
+
+AM_CONDITIONAL(DBUS_USE_MCS, test x$enable_mono = xyes)
+
changequote(,)dnl
# let ourselves use our own unstable API
CPPFLAGS="-DDBUS_API_SUBJECT_TO_CHANGE=1 $CPPFLAGS"
@@ -736,6 +794,8 @@ Makefile
dbus/Makefile
glib/Makefile
qt/Makefile
+gcj/Makefile
+mono/Makefile
bus/Makefile
tools/Makefile
test/Makefile
@@ -765,8 +825,29 @@ echo "
cppflags: ${CPPFLAGS}
cxxflags: ${CXXFLAGS}
Doxygen: ${DOXYGEN}
- db2html: ${DB2HTML}
+ db2html: ${DB2HTML}"
+
+if test x$enable_gcj = xyes ; then
+echo \
+" gcj: ${GCJ}
+ gcjflags: ${GCJFLAGS}"
+else
+echo \
+" gcj: (not enabled)"
+fi
+
+if test x$enable_mono = xyes ; then
+echo \
+" mcs: ${MCS}
+ mcsflags: ${MCSFLAGS}
+"
+else
+echo \
+" mcs: (not enabled)
+"
+fi
+echo "
Maintainer mode: ${USE_MAINTAINER_MODE}
gcc coverage profiling: ${enable_gcov}
Building unit tests: ${enable_tests}