summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-10-10 03:56:30 +0000
committerHavoc Pennington <hp@redhat.com>2003-10-10 03:56:30 +0000
commitc1f0e189030ceb2bafea0bc30d6b72a0fa381ddc (patch)
tree7eb6d2c7a43003f9d1193b5d6c73b4a565502e20 /configure.in
parent6a65f4802e95ba442c520f8e225da837e0a9f73b (diff)
2003-10-09 Havoc Pennington <hp@redhat.com>
* configure.in: define DBUS_HAVE_GCC33_GCOV if we have gcc 3.3. Not that we do anything about it yet. * bus/signals.c (bus_match_rule_parse): impose max length on the match rule text * dbus/dbus-protocol.h: add DBUS_MAXIMUM_MATCH_RULE_LENGTH
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8a2c7aad..e128fddf 100644
--- a/configure.in
+++ b/configure.in
@@ -223,6 +223,15 @@ changequote([,])dnl
if test x$enable_gcov = xyes; then
## so that config.h changes when you toggle gcov support
AC_DEFINE_UNQUOTED(DBUS_GCOV_ENABLED, 1, [Defined if gcov is enabled to force a rebuild due to config.h changing])
+
+ AC_MSG_CHECKING([for gcc 3.3 version of gcov file format])
+ have_gcc33_gcov=no
+ AC_RUN_IFELSE( [AC_LANG_PROGRAM( , [[ if (__GNUC__ >=3 && __GNUC_MINOR__ >= 3) exit (0); else exit (1); ]])],
+ have_gcc33_gcov=yes)
+ if test x$have_gcc33_gcov = xyes ; then
+ AC_DEFINE_UNQUOTED(DBUS_HAVE_GCC33_GCOV, 1, [Defined if we have gcc 3.3 and thus the new gcov format])
+ fi
+ AC_MSG_RESULT($have_gcc33_gcov)
fi
AM_CONDITIONAL(DBUS_GCOV_ENABLED, test x$enable_gcov = xyes)