summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorOlivier Andrieu <oliv__a@users.sourceforge.net>2004-06-22 11:58:13 +0000
committerOlivier Andrieu <oliv__a@users.sourceforge.net>2004-06-22 11:58:13 +0000
commit94066150185141b6533233a7862e0343b9a0bba4 (patch)
tree88b7296c2018db8bf25afe9966108e17216f0340 /configure.in
parent961e6ca41c1e9433055130569ce3492866e2126b (diff)
2004-06-22 Olivier Andrieu <oliv__a@users.sourceforge.net>
* configure.in: prevent building the gcj stuff and libxml loader since they are broken.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 13 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index a43e11c2..cfab621f 100644
--- a/configure.in
+++ b/configure.in
@@ -166,13 +166,14 @@ else
AC_SUBST(GCJFLAGS)
fi
-if test x$enable_gcj = xauto ; then
- if test x$have_gcj = xno ; then
- enable_gcj=no
- else
- enable_gcj=yes
- fi
-fi
+dnl Commenting this out so that gcj stuff won't get built unless explicitly required
+# if test x$enable_gcj = xauto ; then
+# if test x$have_gcj = xno ; then
+# enable_gcj=no
+# else
+# enable_gcj=yes
+# fi
+# fi
if test x$enable_gcj = xyes; then
if test x$have_gcj = xno ; then
@@ -672,6 +673,11 @@ else
fi
fi
+if $dbus_use_libxml ; then
+ dnl libxml loader is broken
+ AC_MSG_ERROR([libxml loader is broken ATM, use the expat loader])
+fi
+
AM_CONDITIONAL(DBUS_USE_EXPAT, $dbus_use_expat)
AM_CONDITIONAL(DBUS_USE_LIBXML, $dbus_use_libxml)