summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Shaw <joeshaw@novell.com>2004-08-17 17:08:32 +0000
committerJoe Shaw <joeshaw@novell.com>2004-08-17 17:08:32 +0000
commit00f0e76788c706cefe407dd7d43d08abb0d00ab6 (patch)
tree0429391d9d40f1c6684830bfb0e3aafb05ccca49 /configure.in
parent224d88bc1f08f130d9f3347d6dab911306709578 (diff)
2004-08-17 Joe Shaw <joeshaw@novell.com>
* configure.in: If --enable-mono is passed in, if we can't find mono error out. * mono/Makefile.am: Use /gacutil to install assemblies into the GAC and not /root.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 21 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 36494e41..34d69e87 100644
--- a/configure.in
+++ b/configure.in
@@ -189,23 +189,29 @@ MONO_REQUIRED_VERSION=0.95
AC_SUBST(MONO_REQUIRED_VERSION)
PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= $MONO_REQUIRED_VERSION, have_mono=true, have_mono=false)
-if test "x$have_mono" = "xtrue"; then
-if test `uname -s` = "Darwin"; then
- AC_PATH_PROG(RUNTIME, mint, no)
- AC_PATH_PROG(CSC, mcs, no)
- LIB_PREFIX=
- LIB_SUFFIX=.dylib
-else
- AC_PATH_PROG(RUNTIME, mono, no)
- AC_PATH_PROG(CSC, mcs, no)
- LIB_PREFIX=.so
- LIB_SUFFIX=
+if test "x$enable_mono" = "xyes"; then
+ if test "x$have_mono" = "xfalse"; then
+ AC_MSG_ERROR([Mono was not found])
+ fi
fi
+
+if test "x$have_mono" = "xtrue"; then
+ if test `uname -s` = "Darwin"; then
+ AC_PATH_PROG(RUNTIME, mint, no)
+ AC_PATH_PROG(CSC, mcs, no)
+ LIB_PREFIX=
+ LIB_SUFFIX=.dylib
+ else
+ AC_PATH_PROG(RUNTIME, mono, no)
+ AC_PATH_PROG(CSC, mcs, no)
+ LIB_PREFIX=.so
+ LIB_SUFFIX=
+ fi
else
-AC_PATH_PROG(CSC, csc.exe, no)
-RUNTIME=
-LIB_PREFIX=
-LIB_SUFFIX=.dylib
+ AC_PATH_PROG(CSC, csc.exe, no)
+ RUNTIME=
+ LIB_PREFIX=
+ LIB_SUFFIX=.dylib
fi
if test x$enable_mono = xyes; then