summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2005-06-15 02:31:38 +0000
committerDavid Zeuthen <davidz@redhat.com>2005-06-15 02:31:38 +0000
commit1d19fc62e9034cc5700c0903f68787a84f485315 (patch)
tree6d0da2b8c889fefa111cc695b42d4b83e97ff237 /configure.in
parent50f85baa3d92657a6c77c450a8f6dc34206e0610 (diff)
2005-06-14 David Zeuthen <davidz@redhat.com>
* bus/bus.c (process_config_every_time): Drop existing conf-dir watches (if applicable) and add new watches * bus/main.c (signal_handler): Handle SIGIO if using D_NOTIFY (main): Setup SIGIO signal handler if using D_NOTIFY * bus/config-parser.h: Add prototype bus_config_parser_get_conf_dirs * bus/config-parser.c (struct BusConfigParser): Add conf_dirs list (merge_included): Also merge conf_dirs list (bus_config_parser_unref): Clear conf_dirs list (include_dir): Add directory to conf_dirs list (bus_config_parser_get_conf_dirs): New function * bus/dir-watch.[ch]: New files * bus/Makefile.am (BUS_SOURCES): Add dir-watch.[ch] * configure.in: Add checks for D_NOTIFY on Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6da1d953..dca985cf 100644
--- a/configure.in
+++ b/configure.in
@@ -7,6 +7,8 @@ AM_INIT_AUTOMAKE(dbus, 0.34)
AM_CONFIG_HEADER(config.h)
+AC_CANONICAL_TARGET
+
# Honor aclocal flags
ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
@@ -822,6 +824,22 @@ else
SELINUX_LIBS=
fi
+# dnotify checks
+if test x$target_os = xlinux-gnu; then
+ AC_ARG_ENABLE(dnotify,
+ [ --disable-dnotify Disable using dnotify on Linux],
+ [case "${enableval}" in
+ yes) dnotify=false ;;
+ no) dnotify=true ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-dnotify) ;;
+ esac],[dnotify=true])
+fi
+dnl check if dnotify backend is enabled
+if test x$dnotify = xtrue; then
+ AC_DEFINE(DBUS_BUS_ENABLE_DNOTIFY_ON_LINUX,1,[Use dnotify on Linux])
+fi
+
+
#### Set up final flags
DBUS_CLIENT_CFLAGS=
DBUS_CLIENT_LIBS=