summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorOlivier Andrieu <oliv__a@users.sourceforge.net>2004-07-29 08:00:45 +0000
committerOlivier Andrieu <oliv__a@users.sourceforge.net>2004-07-29 08:00:45 +0000
commit4076d31c71bee332c4a697597a93345b45850b33 (patch)
treeb9526969be83df9ddd5ae4f9584410d0ffecf643 /configure.in
parentb72fe8c67d724d0f4637714a72e4e91c9487349f (diff)
* bus/config-loader-libxml.c: complete the implementation of libxml
backend for config file loader. Doesn't work with full OOM test yet. * configure.in: change error when selecting libxml into a warning. * test/data/invalid-config-files: add two non-well-formed XML files. * glib/Makefile.am: libdbus_gtool always uses expat, not libxml. * dbus/dbus-transport-unix.c (unix_handle_watch): do not disconnect in case of DBUS_WATCH_HANGUP, several do_reading() may be necessary to read all the buffer. (bug #894) * bus/activation.c (bus_activation_activate_service): fix a potential assertion failure (bug #896). Small optimization in the case of auto-activation messages. * dbus/dbus-message.c (verify_test_message, _dbus_message_test): add test case for byte-through-vararg bug (#901). patch by Kimmo Hämäläinen.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 17b34018..2c18dd45 100644
--- a/configure.in
+++ b/configure.in
@@ -673,10 +673,11 @@ else
fi
if $dbus_use_libxml ; then
- dnl libxml loader is broken
- AC_MSG_ERROR([libxml loader is broken ATM, use the expat loader])
+ dnl libxml OOM handling is a bit broken
+ AC_MSG_WARN([libxml loader is not as robust as the expat one wrt. OOM handling])
fi
+
AM_CONDITIONAL(DBUS_USE_EXPAT, $dbus_use_expat)
AM_CONDITIONAL(DBUS_USE_LIBXML, $dbus_use_libxml)