summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2004-10-25 18:48:58 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2004-10-25 18:48:58 +0000
commit4612de0198e3417ca710be2bd0c27f4445c6766a (patch)
tree04fd07452e9bed8256743fcf744974370eaee58e /configure.in
parent41a9bdeba10efe28adc34756535578a38a4db7af (diff)
John (J5) Palmieri <johnp@redhat.com>
* dbus/dbus-sysdeps.c (fill_user_info): On errors do not free the DBusUserInfo structure since this is passed into the function. This would cause a double free when the function that allocated the structure would try to free it when an error occured. * (bus/session.conf.in, bus/Makefile.am, dbus/configure.in): use /usr/share/dbus-1/services instead of /usr/lib/dbus-1.0/services for service activation to avoid 32bit/64bit parallel install issues
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ea25336d..e9c6c100 100644
--- a/configure.in
+++ b/configure.in
@@ -984,6 +984,10 @@ LIBDIR_TMP="$libdir"
EXPANDED_LIBDIR=`eval echo $LIBDIR_TMP`
AC_SUBST(EXPANDED_LIBDIR)
+DATADIR_TMP="$datadir"
+EXPANDED_DATADIR=`eval echo $DATADIR_TMP`
+AC_SUBST(EXPANDED_DATADIR)
+
## put prefix and exec_prefix back
prefix=$old_prefix
exec_prefix=$old_exec_prefix
@@ -1168,6 +1172,7 @@ echo "
bindir: ${EXPANDED_BINDIR}
sysconfdir: ${EXPANDED_SYSCONFDIR}
localstatedir: ${EXPANDED_LOCALSTATEDIR}
+ datadir: ${EXPANDED_DATADIR}
source code location: ${srcdir}
compiler: ${CC}
cflags: ${CFLAGS}