summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarald Fernengel <harry@kdevelop.org>2005-09-30 15:20:08 +0000
committerHarald Fernengel <harry@kdevelop.org>2005-09-30 15:20:08 +0000
commit57b6fd3894d0563e0dcc64bc498067ef69f61291 (patch)
tree22fe337ecb429e28a1197de80b19ada1a112ff35 /configure.in
parentfe9f471950c7a061289efe734c20074d5c357f20 (diff)
bring Qt3 library back. Some apps that are not in the KDE trunk are using it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in47
1 files changed, 47 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 03ee6554..aede5818 100644
--- a/configure.in
+++ b/configure.in
@@ -47,6 +47,7 @@ AC_ISC_POSIX
AC_HEADER_STDC
AC_ARG_ENABLE(qt, [ --enable-qt enable Qt-friendly client library],enable_qt=$enableval,enable_qt=auto)
+AC_ARG_ENABLE(qt3, [ --enable-qt3 enable Qt3-friendly client library],enable_qt3=$enableval,enable_qt3=auto)
AC_ARG_ENABLE(glib, [ --enable-glib enable GLib-friendly client library],enable_glib=$enableval,enable_glib=auto)
AC_ARG_ENABLE(gtk, [ --enable-gtk enable GTK-requiring executables],enable_gtk=$enableval,enable_gtk=auto)
AC_ARG_ENABLE(tests, [ --enable-tests enable unit test code],enable_tests=$enableval,enable_tests=$USE_MAINTAINER_MODE)
@@ -928,6 +929,50 @@ AC_SUBST(DBUS_GTK_THREADS_CFLAGS)
AC_SUBST(DBUS_GTK_THREADS_LIBS)
+dnl Qt3 detection
+AC_PATH_PROG(QT3_MOC, moc, no)
+
+have_qt=no
+AC_MSG_CHECKING([for qglobal.h])
+if test -n "$QTDIR" -a -f "$QTDIR/include/qglobal.h"; then
+ have_qt=yes
+ DBUS_QT3_CXXFLAGS="-I$QTDIR/include"
+else
+ for dir in "${prefix}/include/qt" "/usr/include/qt-3.1" "/usr/include/qt3" "/usr/include/qt" "/usr/lib/qt/include" "/usr/lib/qt-3.1/include"; do
+ if test -f "$dir/qglobal.h"; then
+ have_qt3=yes
+ DBUS_QT3_CXXFLAGS="-I$dir"
+ DBUS_QT3_LIBS="-L$QTDIR/lib -lqt-mt"
+ fi
+ done
+fi
+if test x"$have_qt3" = x"yes"; then
+ AC_MSG_RESULT([found])
+else
+ AC_MSG_RESULT([not found])
+fi
+
+if test x$have_qt3 = xno ; then
+ AC_MSG_WARN([Qt3 development libraries not found])
+fi
+
+if test x$enable_qt3 = xyes; then
+ if test x$have_qt3 = xno; then
+ AC_MSG_ERROR([Qt3 integration explicitly required, and Qt3 libraries not found])
+ fi
+fi
+
+if test x$enable_qt3 = xno; then
+ have_qt3=no;
+fi
+
+AM_CONDITIONAL(HAVE_QT3, test x$have_qt3 = xyes)
+
+dnl Qt flags
+AC_SUBST(DBUS_QT3_CXXFLAGS)
+AC_SUBST(DBUS_QT3_LIBS)
+
+
dnl Qt detection
PKG_CHECK_MODULES(DBUS_QT, QtCore >= 4.0, have_qt=yes, have_qt=no)
@@ -1286,6 +1331,7 @@ glib/examples/statemachine/Makefile
python/Makefile
python/examples/Makefile
qt/Makefile
+qt3/Makefile
gcj/Makefile
gcj/org/Makefile
gcj/org/freedesktop/Makefile
@@ -1370,6 +1416,7 @@ echo "
Building assertions: ${enable_asserts}
Building checks: ${enable_checks}
Building Qt bindings: ${have_qt}
+ Building Qt3 bindings: ${have_qt3}
Building GLib bindings: ${have_glib}
Building Python bindings: ${have_python}
Building SELinux support: ${have_selinux}