summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2005-05-18 15:44:50 +0000
committerHavoc Pennington <hp@redhat.com>2005-05-18 15:44:50 +0000
commit7befbf52705a45fccb67e7cc5edd7d4cf30e6fd4 (patch)
tree0e5ff90045b1270f4b49123da18300363ec86d45 /configure.in
parent63ac302bab3fee5abf0241b160bc51792511de5d (diff)
2005-05-18 Havoc Pennington <hp@redhat.com>
* configure.in: use GLIB_GNU_GETTEXT to get INTLLIBS and require gettext. Not really worth requiring yet perhaps, but any production quality 1.0 would require it so we should go ahead and get things set up. We do have a couple token calls to bindtextdomain in the code already.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 22 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 111ef6c8..6da1d953 100644
--- a/configure.in
+++ b/configure.in
@@ -715,10 +715,28 @@ fi
# unix:path=/foo or unix:abstract=/foo
AC_SUBST(DBUS_PATH_OR_ABSTRACT)
+#### Sort out gettext
+
+# this makes us require GLib to run autoconf, but not at runtime
+ALL_LINGUAS=""
+AM_GLIB_GNU_GETTEXT
+
+# INTLLIBS is now set
+
+# (if someone wants to go through and make internationalization
+# conditional with #ifdef ENABLE_NLS then go crazy and send us a patch,
+# but right now we won't build without gettext)
+if test "$gt_cv_have_gettext" != "yes" ; then
+ AC_MSG_ERROR([
+*** You must have either have gettext support in your C library, or use the
+*** GNU gettext library. (http://www.gnu.org/software/gettext/gettext.html
+])
+fi
+
#### Sort out XML library
# see what we have
-AC_CHECK_LIB(expat, XML_ParserCreate_MM,
+AC_CHECK_LIB(expat, XML_ParserCreate_MM,
[ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ],
have_expat=false)
@@ -811,7 +829,7 @@ AC_SUBST(DBUS_CLIENT_CFLAGS)
AC_SUBST(DBUS_CLIENT_LIBS)
DBUS_BUS_CFLAGS=$XML_CFLAGS
-DBUS_BUS_LIBS="$XML_LIBS $SELINUX_LIBS"
+DBUS_BUS_LIBS="$XML_LIBS $SELINUX_LIBS $INTLLIBS"
AC_SUBST(DBUS_BUS_CFLAGS)
AC_SUBST(DBUS_BUS_LIBS)
@@ -854,7 +872,7 @@ AC_SUBST(DBUS_GLIB_LIBS)
AC_SUBST(DBUS_GLIB_THREADS_LIBS)
DBUS_GLIB_TOOL_CFLAGS=$XML_CFLAGS
-DBUS_GLIB_TOOL_LIBS=$XML_LIBS
+DBUS_GLIB_TOOL_LIBS="$XML_LIBS $INTLLIBS"
AC_SUBST(DBUS_GLIB_TOOL_CFLAGS)
AC_SUBST(DBUS_GLIB_TOOL_LIBS)
@@ -1315,6 +1333,7 @@ echo "
Building X11 code: ${enable_x11}
Building Doxygen docs: ${enable_doxygen_docs}
Building XML docs: ${enable_xml_docs}
+ Gettext libs (empty OK): ${INTLLIBS}
Using XML parser: ${with_xml}
Init scripts style: ${with_init_scripts}
Abstract socket names: ${have_abstract_sockets}