summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Shaw <joeshaw@novell.com>2005-07-08 14:36:22 +0000
committerJoe Shaw <joeshaw@novell.com>2005-07-08 14:36:22 +0000
commitb1e21dad20a42eb000ec4c850e416a0dc7d63fe6 (patch)
treedd628097144351985339a728ad607a0aafd71fac /configure.in
parent2ca6e95764dc3491458dcf077ce77cbbabf00ddf (diff)
2005-07-08 Joe Shaw <joeshaw@novell.com>
* configure.in: Add a configure option, --with-console-auth-dir * dbus/dbus-sysdeps-util.c (_dbus_user_at_console): Use the new setting. Patch from Kay Sievers.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 600a8deb..4c77ea54 100644
--- a/configure.in
+++ b/configure.in
@@ -70,6 +70,7 @@ AC_ARG_WITH(session-socket-dir, [ --with-session-socket-dir=[dirname] Where to
AC_ARG_WITH(test-socket-dir, [ --with-test-socket-dir=[dirname] Where to put sockets for make check])
AC_ARG_WITH(system-pid-file, [ --with-system-pid-file=[pidfile] PID file for systemwide daemon])
AC_ARG_WITH(system-socket, [ --with-system-socket=[filename] UNIX domain socket for systemwide daemon])
+AC_ARG_WITH(console-auth-dir, [ --with-console-auth-dir=[dirname] directory to check for console ownerhip])
dnl DBUS_BUILD_TESTS controls unit tests built in to .c files
dnl and also some stuff in the test/ subdir
@@ -1167,6 +1168,16 @@ fi
AC_SUBST(DBUS_SYSTEM_PID_FILE)
+#### Directory to check for console ownership
+if ! test -z "$with_console_auth_dir"; then
+ DBUS_CONSOLE_AUTH_DIR=$with_console_auth_dir
+else
+ DBUS_CONSOLE_AUTH_DIR=/var/run/console/
+fi
+
+AC_SUBST(DBUS_CONSOLE_AUTH_DIR)
+AC_DEFINE_UNQUOTED(DBUS_CONSOLE_AUTH_DIR, "$DBUS_CONSOLE_AUTH_DIR", [Directory to check for console ownerhip])
+
#### Tell tests where to find certain stuff in builddir
ABSOLUTE_TOP_BUILDDIR=`cd ${ac_top_builddir}. && pwd`
@@ -1360,6 +1371,7 @@ echo "
System bus address: ${DBUS_SYSTEM_BUS_DEFAULT_ADDRESS}
System bus PID file: ${DBUS_SYSTEM_PID_FILE}
Session bus socket dir: ${DBUS_SESSION_SOCKET_DIR}
+ Console auth dir: ${DBUS_CONSOLE_AUTH_DIR}
'make check' socket dir: ${TEST_SOCKET_DIR}
"