summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2005-07-15 17:28:35 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2005-07-15 17:28:35 +0000
commitb52d8bbdd442041e0bd494957d8388f26359aa4d (patch)
tree98d0df94c03afa9697c2b52d29d4f2465bf0cda2 /configure.in
parenta7595655fb892b4ecab852aeb971cf53bdff09cc (diff)
* ChangeLog: fix date in last entry
* configure.in, bus/system.conf.in: add the ability to configure the system bus user at compiletime with the --with-dbus-user flag (patch from Kristof Vansant)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 66fae85b..e0f4fa96 100644
--- a/configure.in
+++ b/configure.in
@@ -71,6 +71,7 @@ AC_ARG_WITH(test-socket-dir, [ --with-test-socket-dir=[dirname] Where to
AC_ARG_WITH(system-pid-file, [ --with-system-pid-file=[pidfile] PID file for systemwide daemon])
AC_ARG_WITH(system-socket, [ --with-system-socket=[filename] UNIX domain socket for systemwide daemon])
AC_ARG_WITH(console-auth-dir, [ --with-console-auth-dir=[dirname] directory to check for console ownerhip])
+AC_ARG_WITH(dbus_user, [ --with-dbus-user=<user> User for running the DBUS daemon (messagebus)])
dnl DBUS_BUILD_TESTS controls unit tests built in to .c files
dnl and also some stuff in the test/ subdir
@@ -1178,6 +1179,15 @@ fi
AC_SUBST(DBUS_CONSOLE_AUTH_DIR)
AC_DEFINE_UNQUOTED(DBUS_CONSOLE_AUTH_DIR, "$DBUS_CONSOLE_AUTH_DIR", [Directory to check for console ownerhip])
+#### User to start the system bus as
+if test -z "$with_dbus_user" ; then
+ DBUS_USER=messagebus
+else
+ DBUS_USER=$with_dbus_user
+fi
+AC_SUBST(DBUS_USER)
+AC_DEFINE_UNQUOTED(DBUS_USER,"$DBUS_USER", [User for running the system BUS daemon])
+
#### Tell tests where to find certain stuff in builddir
ABSOLUTE_TOP_BUILDDIR=`cd ${ac_top_builddir}. && pwd`
@@ -1376,6 +1386,7 @@ echo "
System bus PID file: ${DBUS_SYSTEM_PID_FILE}
Session bus socket dir: ${DBUS_SESSION_SOCKET_DIR}
Console auth dir: ${DBUS_CONSOLE_AUTH_DIR}
+ System bus user: ${DBUS_USER}
'make check' socket dir: ${TEST_SOCKET_DIR}
"