summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarald Fernengel <harry@kdevelop.org>2005-09-23 16:24:36 +0000
committerHarald Fernengel <harry@kdevelop.org>2005-09-23 16:24:36 +0000
commitcd883ae0436e0be1234cd0cde3c2e9a8b994d0e8 (patch)
treee911fc2383e9fc4d91cb51774e4037efa439acd2 /configure.in
parentac2de419da28379195da11120ddb0e19f601aa24 (diff)
adding an autotest and "dbus-ify" the build process and include scheme
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7ffc429e..17c80482 100644
--- a/configure.in
+++ b/configure.in
@@ -943,7 +943,7 @@ fi
if test x$enable_qt = xno; then
have_qt=no;
- fi
+fi
QT_MOC=`$PKG_CONFIG --variable=exec_prefix QtCore`
QT_MOC=${QT_MOC}/bin/moc
@@ -955,6 +955,22 @@ AC_SUBST(DBUS_QT_CFLAGS)
AC_SUBST(DBUS_QT_LIBS)
AC_SUBST(QT_MOC)
+dnl QTestLib detection
+PKG_CHECK_MODULES(DBUS_QTESTLIB, QtTest, have_qtest=yes, have_qtest=no)
+
+if test x$have_qtest = xno ; then
+ AC_MSG_WARN([Qt Unit Test library not found])
+fi
+
+if test x$have_qt = xno; then
+ have_qtest=no
+fi
+
+AM_CONDITIONAL(HAVE_QTESTLIB, test x$have_qtest = xyes)
+
+AC_SUBST(DBUS_QTESTLIB_CFLAGS)
+AC_SUBST(DBUS_QTESTLIB_LIBS)
+
### X11 detection
AC_PATH_XTRA
@@ -1276,6 +1292,7 @@ tools/Makefile
test/Makefile
test/glib/Makefile
test/python/Makefile
+test/qt/Makefile
doc/Makefile
dbus-1.pc
dbus-glib-1.pc