summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2005-01-31 02:55:12 +0000
committerHavoc Pennington <hp@redhat.com>2005-01-31 02:55:12 +0000
commitd2c1a633d15611eb6ca757863c489ebf201d07cd (patch)
treecbe676973f4cd3d5b79629aae343240a2a3e12a6 /configure.in
parentd5b7d7a78c0fb2e41d5966a0778b08f8d8e35ea4 (diff)
2005-01-30 Havoc Pennington <hp@redhat.com>
* tools/dbus-names-model.c: dynamically watch NameOwnerChanged * autogen.sh: change to autotools 1.9 * glib/dbus-gproxy.c: completely change how signals work (dbus_g_proxy_add_signal): new function to specify signature of a signal (dbus_g_proxy_emit_received): marshal the dbus message to GValues, and g_warning if the incoming message has the wrong signature.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1df76996..87f214b1 100644
--- a/configure.in
+++ b/configure.in
@@ -819,6 +819,13 @@ fi
AM_CONDITIONAL(HAVE_GLIB, test x$have_glib = xyes)
AM_CONDITIONAL(HAVE_GLIB_THREADS, test x$have_glib_threads = xyes)
+if test x$have_glib = xyes; then
+ GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
+else
+ GLIB_GENMARSHAL=glib-not-enabled-so-there-is-no-genmarshal
+fi
+AC_SUBST(GLIB_GENMARSHAL)
+
dnl GLib flags
AC_SUBST(DBUS_GLIB_CFLAGS)
AC_SUBST(DBUS_GLIB_LIBS)