summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2004-08-23 16:09:54 +0000
committerColin Walters <walters@verbum.org>2004-08-23 16:09:54 +0000
commitee78f2800f2642b4fff962b736296d87a7f12a17 (patch)
tree6ea2949c889f80ae4a4f0f72dee53f277056b0b7 /configure.in
parenta7291aee0e12b9b6abe90f835ef9cb3e158a96c4 (diff)
2004-08-23 Colin Walters <walters@redhat.com>
* bus/selinux.h: Prototype bus_selinux_get_policy_root. * bus/selinux.c: Create a thread for policy reload notification. (bus_selinux_get_policy_root): Implement. Updated SELinux support from Matthew Rickard <mjricka@epoch.ncsc.mil> * bus/config-parser.c (start_busconfig_child) (bus_config_parser_content): Support SELinux-root relative inclusion. * configure.in <HAVE_SELINUX>: Add -lpthread. * bus/test-main.c (test_pre_hook, test_post_hook): New. (test_post_hook): Move memory checking into here. (test_pre_hook, test_post_hook): Move SELinux checks in here, but conditional on a DBUS_TEST_SELINUX environment variable. Unfortunately we can't run the SELinux checks as a normal user, since they won't have any permissions for /selinux. So this will have to be tested manually for now, until we have virtualization for most of libselinux.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 34d69e87..ea25336d 100644
--- a/configure.in
+++ b/configure.in
@@ -724,7 +724,7 @@ fi
AM_CONDITIONAL(HAVE_SELINUX, test x$have_selinux = xyes)
if test x$have_selinux = xyes ; then
- SELINUX_LIBS=-lselinux
+ SELINUX_LIBS="-lselinux -lpthread"
AC_DEFINE(HAVE_SELINUX,1,[SELinux support])
else
SELINUX_LIBS=