summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-08-10 21:00:30 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-08-10 21:00:30 +0000
commit1eba6a2bf0715455512ab2d41051a9b7a5e0d8d8 (patch)
tree594704bba36a25616a3ab9c3d5ad10db774c5c63 /configure.in
parent6f8d6a591f889f9a34c758bea71f3aa8d782894c (diff)
* configure.in: make sure the compiler supports -Wfloat-equal
* bus/dir-watch-dnotify.c: move functional code after variable declerations (C99 fix) (patches from Jens Granseuer <jensgr at gmx dot net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a411262e..48382b56 100644
--- a/configure.in
+++ b/configure.in
@@ -146,7 +146,10 @@ if test "x$GCC" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-Wfloat-equal[\ \ ]*) ;;
- *) CFLAGS="$CFLAGS -Wfloat-equal" ;;
+ *) if cc_supports_flag -Wfloat-equals; then
+ CFLAGS="$CFLAGS -Wfloat-equal"
+ fi
+ ;;
esac
case " $CFLAGS " in