summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-10-26 15:55:44 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-10-26 15:55:44 +0000
commita107da84891f941d591bcaa99641f4058f089c7d (patch)
treebbf7d763a721c2e134a51a3262ff8437d18bde9e /configure.in
parent36608068cf84eca2a0e074fe6b1c416a4a8a2b08 (diff)
* tools/dbus-launch.c (main): run the dbus-daemon in the builddir
if tests are enabled and the DBUS_USE_TEST_BINARY env variable is set * tools/run-with-tmp-session-bus.sh: set DBUS_USE_TEST_BINARY before we run dbus-launch * configure.in: define TEST_BUS_BINARY to be the full path to dbus-daemon in the build root
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0a5fdbb4..9efd8178 100644
--- a/configure.in
+++ b/configure.in
@@ -1138,6 +1138,10 @@ TEST_PATH(EXIT_BINARY, test-exit)
TEST_PATH(SEGFAULT_BINARY, test-segfault)
TEST_PATH(SLEEP_FOREVER_BINARY, test-sleep-forever)
+AC_DEFINE_UNQUOTED(TEST_BUS_BINARY, "$DBUS_PWD/bus/dbus-daemon",
+ [Full path to the daemon in the builddir])
+AC_SUBST(TEST_BUS_BINARY)
+
#### Find socket directories
if ! test -z "$TMPDIR" ; then
DEFAULT_SOCKET_DIR=$TMPDIR