summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2002-11-25 05:13:09 +0000
committerHavoc Pennington <hp@redhat.com>2002-11-25 05:13:09 +0000
commit041b0767b284034aee09e9a0de2a3844b8cc546a (patch)
tree8ef9cce16d743350971696ff6333ce43686c7ac0 /dbus/Makefile.am
parent576cdb6e0b1274e9fa5276e01337aef330dd4e8c (diff)
2002-11-24 Havoc Pennington <hp@pobox.com>
* test/echo-client.c, test/echo-server.c: cheesy test clients. * configure.in (AC_CHECK_FUNCS): check for writev * dbus/dbus-message.c (_dbus_message_get_network_data): new function * dbus/dbus-list.c (_dbus_list_foreach): new function * dbus/dbus-internals.c (_dbus_verbose): new function * dbus/dbus-server.c, dbus/dbus-server.h: public object representing a server that listens for connections. * dbus/.cvsignore: create * dbus/dbus-errors.h, dbus/dbus-errors.c: public API for reporting errors * dbus/dbus-connection.h, dbus/dbus-connection.c: public object representing a connection that sends/receives messages. (Same object used for both client and server.) * dbus/dbus-transport.h, dbus/dbus-transport.c: Basic abstraction for different kinds of stream that we might read/write messages from.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am24
1 files changed, 22 insertions, 2 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 46d703f0..f830bb7b 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -7,18 +7,38 @@ lib_LTLIBRARIES=libdbus-1.la
dbusinclude_HEADERS= \
dbus.h \
+ dbus-errors.h \
dbus-macros.h \
dbus-memory.h \
dbus-message.h \
+ dbus-server.h \
dbus-types.h
libdbus_1_la_SOURCES= \
+ dbus-connection.c \
+ dbus-connection-internal.h \
+ dbus-errors.c \
dbus-memory.c \
- dbus-message.c
+ dbus-message.c \
+ dbus-message-internal.h \
+ dbus-server.c \
+ dbus-server-protected.h \
+ dbus-server-unix.c \
+ dbus-server-unix.h \
+ dbus-transport.c \
+ dbus-transport.h \
+ dbus-transport-protected.h \
+ dbus-transport-unix.c \
+ dbus-transport-unix.h \
+ dbus-watch.c \
+ dbus-watch.h
+
## this library is linked into both libdbus and the bus
## itself, but does not export any symbols from libdbus.
-## It contains utility functions not in the public API.
+## i.e. the point is to contain symbols that we don't
+## want the shared lib to export, but we do want the
+## message bus to be able to use.
noinst_LTLIBRARIES=libdbus-convenience.la