summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2002-12-24 06:37:33 +0000
committerHavoc Pennington <hp@redhat.com>2002-12-24 06:37:33 +0000
commit17fbe2b702cdc880abd6cbe117e620b6432f42e0 (patch)
tree9dc357f6d6c5cd7dd4bfa2bc0dee1760d4ac366a /dbus/Makefile.am
parent7af22a5ef9460af0f6afc2f1704d44b2e4c18ead (diff)
2002-12-24 Havoc Pennington <hp@pobox.com>
* glib/dbus-gthread.c: fix include * glib/dbus-glib.h: rename DBusMessageHandler for now. I think glib API needs to change, though, as you don't want to use DBusMessageFunction, you want to use the DBusMessageHandler object. Probably dbus_connection_open_with_g_main_loop() and dbus_connection_setup_g_main_loop() or something like that (but think of better names...) that just create a connection that has watch/timeout functions etc. already set up. * dbus/dbus-connection.c (dbus_connection_send_message_with_reply): new function just to show how the message handler helps us deal with replies. * dbus/dbus-list.c (_dbus_list_remove_last): new function * dbus/dbus-string.c (_dbus_string_test): free a string that wasn't * dbus/dbus-hash.c: use memory pools for the hash entries (rebuild_table): be more paranoid about overflow, and shrink table when we can (_dbus_hash_test): reduce number of sprintfs and write valid C89. Add tests for case where we grow and then shrink the hash table. * dbus/dbus-mempool.h, dbus/dbus-mempool.c: memory pools * dbus/dbus-connection.c (dbus_connection_register_handler) (dbus_connection_unregister_handler): new functions * dbus/dbus-message.c (dbus_message_get_name): new * dbus/dbus-list.c: fix docs typo * dbus/dbus-message-handler.h, dbus/dbus-message-handler.c: an object representing a handler for messages.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index b5071f0b..74b5dfbb 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -11,6 +11,7 @@ dbusinclude_HEADERS= \
dbus-macros.h \
dbus-memory.h \
dbus-message.h \
+ dbus-message-handler.h \
dbus-server.h \
dbus-threads.h \
dbus-types.h
@@ -21,6 +22,7 @@ libdbus_1_la_SOURCES= \
dbus-errors.c \
dbus-memory.c \
dbus-message.c \
+ dbus-message-handler.c \
dbus-message-internal.h \
dbus-server.c \
dbus-server-protected.h \
@@ -51,6 +53,8 @@ libdbus_convenience_la_SOURCES= \
dbus-internals.h \
dbus-list.c \
dbus-list.h \
+ dbus-mempool.c \
+ dbus-mempool.h \
dbus-string.c \
dbus-string.h \
dbus-sysdeps.c \