summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-01-18 14:41:37 +0000
committerHavoc Pennington <hp@redhat.com>2003-01-18 14:41:37 +0000
commit368e150afc8c71fd94f90643f7079d20cdc7f913 (patch)
tree8745ef479fa45d4cf26ace66bff03b4bbbd26b23 /dbus/Makefile.am
parent59d131e431db675d461fe6887cb9ea2300c6b194 (diff)
2003-01-18 Havoc Pennington <hp@pobox.com>
* configure.in: default --enable-tests to $USE_MAINTAINER_MODE * dbus/Makefile.am: fix it up so dubs-test-main.c is included in the distribution * test/Makefile.am: don't use special variable "TESTS" for echo-* since we don't want to use those in make check
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 3457534d..955b793f 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -73,14 +73,20 @@ libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS) libdbus-convenience.la
## convention for internal symbols)
libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*"
+## note that TESTS has special meaning (stuff to use in make check)
+## so if adding tests not to be run in make check, don't add them to
+## TESTS
if DBUS_BUILD_TESTS
-noinst_PROGRAMS=dbus-test
+TESTS=dbus-test
+else
+TESTS=
+endif
+
+## we use noinst_PROGRAMS not check_PROGRAMS so that we build
+## even when not doing "make check"
+noinst_PROGRAMS=$(TESTS)
dbus_test_SOURCES= \
dbus-test-main.c
dbus_test_LDADD= $(DBUS_CLIENT_LIBS) libdbus-convenience.la libdbus-1.la
-
-## so that "make check" works
-TESTS=dbus-test
-endif