summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2002-11-23 19:56:30 +0000
committerHavoc Pennington <hp@redhat.com>2002-11-23 19:56:30 +0000
commit576cdb6e0b1274e9fa5276e01337aef330dd4e8c (patch)
tree6904e387bd7f70f0452abe8b4359f66070965d33 /dbus/Makefile.am
parentf09921965c769ff6411ae2f684f6b855d4c8f38d (diff)
2002-11-23 Havoc Pennington <hp@pobox.com>
* dbus/dbus-internals.h (_DBUS_INT_MAX): add _DBUS_INT_MIN _DBUS_INT_MAX * dbus/dbus-test.c (main): add list test, and include dbus-test.h as intended * dbus/dbus-hash.c (_dbus_hash_table_remove_string) (_dbus_hash_table_remove_int): return value indicates whether the entry existed to remove * dbus/dbus-list.c: add linked list utility class, with docs and tests * dbus/dbus-hash.c: add TODO item about shrinking the hash bucket array sometimes.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 56b519e2..46d703f0 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -26,7 +26,9 @@ libdbus_convenience_la_SOURCES= \
dbus-hash.c \
dbus-hash.h \
dbus-internals.c \
- dbus-internals.h
+ dbus-internals.h \
+ dbus-list.c \
+ dbus-list.h
libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS) libdbus-convenience.la
## don't export symbols that start with "_" (we use this