summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorAnders Carlsson <andersca@codefactory.se>2003-01-28 14:26:49 +0000
committerAnders Carlsson <andersca@codefactory.se>2003-01-28 14:26:49 +0000
commitdec1fa3bd5f106ba5b2c749372231e3dd4bf9e7b (patch)
tree9a579d3d5b908ee5712249b4de696b89a72ffca7 /dbus/Makefile.am
parentbec3c093cab742a953e39f1726c37345873990dc (diff)
2003-01-28 Anders Carlsson <set EMAIL_ADDRESS environment variable>
* dbus/dbus-connection-internal.h: * dbus/dbus-connection.c: (_dbus_connection_add_timeout), (_dbus_connection_remove_timeout): Add functions for adding and removing timeouts. * dbus/dbus-message.c: (dbus_message_new_from_message): Add new function that takes a message and creates an exact copy of it, but with the refcount set to 1. (check_message_handling): Fix build error. * dbus/dbus-server-protected.h: * dbus/dbus-server.c: (_dbus_server_init_base), (_dbus_server_finalize_base), (_dbus_server_add_timeout), (dbus_server_set_timeout_functions): (_dbus_server_remove_timeout): New functions so that a server can add and remove timeouts. (dbus_server_listen): Add commented out call to dbus_server_debug_new. * dbus/dbus-timeout.c: (_dbus_timeout_new): Actually set the handler, doh. * dbus/dbus-transport.c: (_dbus_transport_open): Add commented out call to dbus_transport_debug_client_new. * dbus/Makefile.am: Add dbus-transport-debug.[ch] and dbus-server-debug.[ch]
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 322f86a7..b97ed6b9 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -32,6 +32,8 @@ libdbus_1_la_SOURCES= \
dbus-resources.h \
dbus-server.c \
dbus-server-protected.h \
+ dbus-server-debug.c \
+ dbus-server-debug.h \
dbus-server-unix.c \
dbus-server-unix.h \
dbus-test.c \
@@ -41,6 +43,8 @@ libdbus_1_la_SOURCES= \
dbus-threads.c \
dbus-transport.c \
dbus-transport.h \
+ dbus-transport-debug.c \
+ dbus-transport-debug.h \
dbus-transport-protected.h \
dbus-transport-unix.c \
dbus-transport-unix.h \