summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-02-01 04:58:16 +0000
committerHavoc Pennington <hp@redhat.com>2003-02-01 04:58:16 +0000
commite0ffb6eb1472e6766d79346e1fae418c129ef536 (patch)
tree4fddaa6743cfcae6ef5ccac4105d4242d2408773 /dbus/Makefile.am
parentd8f9c46bf873fe03dbb1db100f3c6d02b2d6c847 (diff)
2003-02-01 Havoc Pennington <hp@pobox.com>
* dbus/dbus-break-loader.c (main): new program to find messages that break the loader. * dbus/dbus-sysdeps.c (_dbus_string_append_uint): new function * dbus/dbus-sysdeps.c (_dbus_string_save_to_file): new function * dbus/dbus-string.c (_dbus_string_set_byte): new
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 98090a62..4ffe7e2c 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -85,12 +85,16 @@ libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS) libdbus-convenience.la
## convention for internal symbols)
libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*"
+## FIXME it would be less annoying when hacking if we didn't have
+## to relink these test binaries, so moving them to the test/*
+## subdir would be nice.
+
## note that TESTS has special meaning (stuff to use in make check)
## so if adding tests not to be run in make check, don't add them to
## TESTS
if DBUS_BUILD_TESTS
TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_srcdir)/test/data
-TESTS=dbus-test
+TESTS=dbus-test dbus-break-loader
else
TESTS=
endif
@@ -103,3 +107,8 @@ dbus_test_SOURCES= \
dbus-test-main.c
dbus_test_LDADD= $(DBUS_CLIENT_LIBS) libdbus-convenience.la libdbus-1.la
+
+dbus_break_loader_SOURCES= \
+ dbus-break-loader.c
+
+dbus_break_loader_LDADD= $(DBUS_CLIENT_LIBS) libdbus-convenience.la libdbus-1.la \ No newline at end of file