summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-03-15 06:00:01 +0000
committerHavoc Pennington <hp@redhat.com>2003-03-15 06:00:01 +0000
commitf05f87a825ab8ed5273674a7f65521ffc526f0d2 (patch)
treea4645e057d269b6bc7d2d99e89ba7606625b3686 /dbus/Makefile.am
parent169238e99a4a163c89eb053250daeedf5f73e5cd (diff)
2003-03-15 Havoc Pennington <hp@pobox.com>
* bus/dispatch.c (bus_dispatch_test): OK, now finally actually write useful test code, after all that futzing around ;-) Test does not yet pass because we can't handle OOM in _dbus_transport_messages_pending (basically, dbus_connection_preallocate_send() does not prealloc the write watch). To fix this, I think we need to add new stuff to set_watch_functions, namely a SetEnabled function so we can alloc the watch earlier, then enable it later. * dbus/Makefile.am (libdbus_convenience_la_SOURCES): move dbus-memory.c to the convenience lib * bus/test.c: rename some static functions to keep them clearly distinct from stuff in connection.c. Handle client disconnection.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index e9b08d13..c66c5367 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -34,7 +34,6 @@ libdbus_1_la_SOURCES= \
dbus-errors.c \
dbus-keyring.c \
dbus-keyring.h \
- dbus-memory.c \
dbus-message.c \
dbus-message-handler.c \
dbus-message-internal.h \
@@ -88,6 +87,7 @@ libdbus_convenience_la_SOURCES= \
dbus-list.h \
dbus-marshal.c \
dbus-marshal.h \
+ dbus-memory.c \
dbus-mempool.c \
dbus-mempool.h \
dbus-message-builder.c \