summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-01 00:21:24 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-01 00:21:24 +0000
commit2e9393ffda9630373018e02680fbd204e9f6ac99 (patch)
tree29d60fbab1891670c205a564740f67723f41ccbd /dbus/Makefile.am
parent18c470cd2c7245f33f5d924d23972e95e3d347a0 (diff)
2003-03-31 Havoc Pennington <hp@redhat.com>
* dbus/dbus-keyring.c (_dbus_keyring_new_homedir): allow setting DBUS_TEST_HOMEDIR when tests are enabled, so we can test without having a real home directory available.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index c7a93b58..9f2f2e7d 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -111,8 +111,8 @@ libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*"
## so if adding tests not to be run in make check, don't add them to
## TESTS
if DBUS_BUILD_TESTS
-TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_srcdir)/test/data
-TESTS=dbus-test
+TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_srcdir)/test/data DBUS_TEST_HOMEDIR=$(top_builddir)/dbus
+TESTS=dbus-test
else
TESTS=
endif