summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-07-07 00:47:01 +0000
committerHavoc Pennington <hp@redhat.com>2003-07-07 00:47:01 +0000
commit3f1ad214b5e5c63697ee208d459b304a4ef6e79b (patch)
tree9912979a2b6989b66c6812f21c24cdde698d032c /dbus/Makefile.am
parent320aac6ce610bfdeedebc39d26a6d27e957275f9 (diff)
2003-07-06 Havoc Pennington <hp@pobox.com>
* dbus/dbus-marshal.c (_dbus_marshal_set_object_id): new function (_dbus_marshal_object_id): new (_dbus_demarshal_object_id): new (_dbus_marshal_get_arg_end_pos): support object ID type, and consolidate identical switch cases. Don't conditionalize handling of DBUS_TYPE_UINT64, need to handle the type always. (_dbus_marshal_validate_arg): consolidate identical cases, and handle DBUS_TYPE_OBJECT_ID * dbus/dbus-objectid.c: new file with DBusObjectID data type. * dbus/dbus-protocol.h: add DBUS_TYPE_OBJECT_ID
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index eac68c6a..3c3c14e7 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -17,6 +17,7 @@ dbusinclude_HEADERS= \
dbus-memory.h \
dbus-message.h \
dbus-message-handler.h \
+ dbus-objectid.h \
dbus-protocol.h \
dbus-server.h \
dbus-threads.h \
@@ -42,6 +43,7 @@ DBUS_LIB_SOURCES= \
dbus-message.c \
dbus-message-handler.c \
dbus-message-internal.h \
+ dbus-objectid.c \
dbus-resources.c \
dbus-resources.h \
dbus-server.c \