summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2002-11-22 22:30:02 +0000
committerHavoc Pennington <hp@redhat.com>2002-11-22 22:30:02 +0000
commit8164139fa6259257817898b3d389d96bd60f8c13 (patch)
tree580a092f9afbe3c1316b9640681a3e82de9a9d1d /dbus/Makefile.am
parent1a4cb6b95ffc3acdef34b6f014a83c02be963fae (diff)
2002-11-22 Havoc Pennington <hp@redhat.com>
* dbus/dbus.h: fixups for doc warnings * Doxyfile.in (FILE_PATTERNS): we need to scan .h to pick up macros (QUIET): make it quiet so we can see warnings * dbus/dbus-memory.c: teach D-BUS to allocate and free memory
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index c233c766..e39897d2 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -8,15 +8,22 @@ lib_LTLIBRARIES=libdbus-1.la
dbusinclude_HEADERS= \
dbus.h \
dbus-macros.h \
+ dbus-memory.h \
dbus-message.h
libdbus_1_la_SOURCES= \
+ dbus-memory.c \
dbus-message.c
+## this library is linked into both libdbus and the bus
+## itself, but does not export any symbols from libdbus.
+## It contains utility functions not in the public API.
+
noinst_LTLIBRARIES=libdbus-convenience.la
libdbus_convenience_la_SOURCES= \
- dbus-hash.c
+ dbus-hash.c \
+ dbus-hash.h
libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS) libdbus-convenience.la
## don't export symbols that start with "_" (we use this